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MicroStation  
 
O MicroStation é um sistema CAD multiplataforma muito difundido em todo o mundo. 
Através de seus modeladores 2D e 3D de alta precisão, pode gerar imagens renderizadas, 
animações, interfaces com bancos de dados e utiliza duas linguagens de programação (MDL e 
UCM) e aplicativos de registro de imagens (georreferenciamento). Além disso, possui 
aplicativos topográficos, como o Geoterrain e aplicativos de análises espaciais, a exemplo o 
MicroStation Geographics. 
 
O MicroStation Básico compreende operações vetoriais com topologias, fazendo desenhos 
bidimensionais com precisão, manipulação e edição de elementos. Pode ser usado em diversas 
áreas, como a arquitetura (para a confecção de plantas e projetos), as engenharias, a geografia, 
a geologia, a biologia, entre outras. 
 
O MicroStation Descartes é indicado para trabalhos relacionados ao manuseio de imagens, a 
saber: georreferenciamento, composição de mosaicos, conversão de dados vetoriais em 
matriciais e vetorização automática e semi-automática. 
 
O MicroStation Geographics desenvolve funções de SIG integradas à plataforma 
MicroStation. Este sistema possui ferramentas para introduzir, validar, administrar, analisar e 
visualizar informações geográficas, permitindo uma variada e extensa combinação de vetores, 
imagens e dados tabulares. 
 

O MicroStation possui ainda o aplicativo topográfico Geoterrain que desenvolve modelos 
digitais de elevação, através dos quais podem ser feitos cálculos precisos de terraplanagem, 
cortes de taludes e seus respectivos volumes, possibilitando inúmeras aplicações nas 
engenharias, por mineradoras, bem como análises geomorfológicas. 

 
 

1. TRABALHO COM MAPAS DIGITAIS GEOMINAS 
 
O estado de Minas Gerais possui amplo acervo de cartografia digital relativa à digitalização de 
mapas topográficos do IGBE, em escalas 1:50.000 e 1:100.000, promovido pelo projeto 
Geominas. O referido acervo se encontra em formato TAB (Mapinfo), contendo as curvas de 
nível em vetores com as cotas altimétricas como atributos associados a estes vetores.  
 
Para usuários de dados de Minas Gerais, constitui etapa importante o trabalho de 
aproveitamento desses dados, posto que a simples exportação como arquivo DXF (Drawing 
Exchage Format) resultaria em arquivos 2d, mas não garantiria o reconhecimento do atributo 
tridimensional.  
 
Apresenta-se aqui o roteiro de tratamento inicial dos dados no Mapinfo, conforme eles se 
encontram no original, seguido de uso do Spring para composição dos dados em DXF 3d, que 
finalmente deve ser levado para o Microstation para a composição do Modelo Digital de 
Terreno. 
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1.1 Preparação de Dados no MapInfo 
 
Menu File→ Open- abrir os arquivos no formato MapInfo (*tab), em: Preferred View → 
Current Mapper caso esteja abrindo mais de um arquivo; 
 
 

 
 
Menu Map→ Layer Control- deixar as curvas de nível somente visíveis (visible) e editáveis 
(editables); 
 

 
 
Usando a ferramenta de seleção Marquee Select selecione as curvas de nível “abertas” nas 
tela de trabalho do MapInfo. 
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O primeiro passo é converter o arquivo para polylineas.  
Menu Objects → Convert to Polylines; - Repetir este procedimento para todos os arquivos 
trabalhados; 
 

 
 
 
 
Menu File → Save Table → Save – salvar todas as polylines geradas;  
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Abrirá então a janela abaixo, na qual você deverá salvar todas as tabelas convertidas para poli 
linha, repetindo o procedimento acima:  
 

 
 
Menu Table → Export – selecione a curva de nível e → Export em formato MapInfo 
Interchange (*mif). 
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Abrirão as janelas abaixo, nas quais você deverá exportar todos os arquivos referentes as 
curvas de nível do seu projeto: 
 

 
 

 
 
 
1.2 Preparação do DXF 3D no No SPRING / INPE 
 
No Spring iremos converter os arquivos MIF em formato ASC, formato legível ao Spring, e 
logo após, importá-los para o ambiente do software. Os dados serão tratados no Spring para 
depois serem exportados no formato DXF para o MicroStation. Tal procedimento é feito no 
Spring devido ao fato de que os arquivos, neste ambiente, não perdem os atributos altimétricos 
ao serem convertidos para DXF, o que é recorrente em outros softwares.  
 
a) Criar um Banco de Dados  
 
Menu Arquivo → Banco de Dados (ou clique no ícone referente a Banco de Dados) – 
Escolher o diretório no qual você irá salvar seu banco de dados.  
 
No campo Nome → dê nome ao seu Banco de Dados.  
 
No campo Gerenciador → Access (gerenciador do seu banco de dados) → Criar → Ativar. 
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b) Criar um projeto 
 
Menu Arquivo → Projeto ( ou clique no ícone referente a Projeto) – No campo Projetos dê 
um nome ao seu projeto e defina o sistema de projeção – Projeção → Projeções→   
Sistemas → UTM (por exemplo). 
 
No campo Modelos da Terra selecione o Datum que melhor se adapta á localização 
geográfica do seu projeto. Caso o sistema de projeção selecionado for UTM, no campo Zona 
você devera digitar o número do fuso no qual se encontra sua área de estudo, clique em CR 
e depois em Executar. 
 
 De volta na janela Projetos→ Campo Retângulo Envolvente: escolha as coordenadas do seu 
projeto (Planas ou Geográficas) e defina o Retângulo Envolvente que abrange seu projeto.  
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Retângulo Envolvente 
Entre com os valores das coordenadas sem pontos, vírgulas e sem as casas decimais!   
Defina em qual hemisfério se encontra seu projeto (Norte ou Sul) → Criar → Ativar. 
 

 
 

OBS: Após definir o projeto abrirá a janela do Painel de Controle, feche-a.  
 
c) Criar um Modelo de Dados 
 
Menu Arquivo → Modelo de Dados ( ou clique no ícone referente a modelo de dados) → 
Categorias → digite um nome.  
Modelo → MNT (Modelo Numérico do Terreno) → Criar → Executar → Fechar;  
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d) Converter o formato MIF para ASCII – SPRING: 
 
Menu Arquivo → Converter para ASCII SPRING – No campo Entrada selecione o arquivo 
(*.mif) que será convertido para ASCII. No campo Modelo SPRING → MNT, no campo 
Atributos → Altitude → Executar → Fechar.  
 

                     
 
OBS: O procedimento anterior deverá ser repetido para cada arquivo (*.mif) a ser 
convertido;  
 
e) Criar um Plano de Informação (PI) 
 
O Plano de informação funciona como um gerenciador das características básicas comuns de 
cada categoria criada no menu Modelo de Dados. 
 
Clique no ícone referente à PI (Quadrado verde na barra de ferramentas), aparecera então a 
tela abaixo: 
 
No campo Nome dê um nome ao seu PI, o campo Retângulo Envolvente... já estará 
configurado conforme foi definido nos passos anteriores. Informe a Escala e a Resolução X e 
Y referentes ao seu projeto, (lembre-se que a precisão cartográfica é de 0,2mm na escala do 
mapa (Padrão A), logo se estivermos trabalhando numa escala de 1:100.000 teremos X= 20 e 
Y=20). Criar → Fechar. 
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f) Importar o arquivo ASCII: 
 
Menu Arquivo → Importar – Ao abrir a janela Importação, o Spring já seleciona o diretório 
no qual se encontra o arquivo ASCII, bem como o seu formato. No entanto você deve 
conferir tais dados e fazer modificações caso necessário.  
No campo Entidade → Amostras MNT, uma vez que o nosso objetivo é gerar uma malha 
triangular ou regular de todo o retângulo envolvente definido, ou seja, sem linha de quebra. 
Em Unid definir a unidade de trabalho. Forneça a escala do mapa e a resolução conforme 
explicado no passo anterior.   
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No campo Categoria → escolher a categoria, em PI dê nome ao seu plano de informação → 
Executar → Fechar. 
 
OBS: caso estiver importando mais de um arquivo ASCII é necessário que  a partir do 
segundo arquivo a opção Mosaico seja selecionada. 
 
Clique no ícone Painel de Controle → Amostra → Desenhar → Fechar. Observe que ao 
marcar o campo Amostras, a Categoria e o PI referentes ao seu projeto aparecem ativados.  
 
As curvas apareceram na tela de trabalho do Spring, conforme a figura abaixo: 
 

 
 
g) Recortar o Plano de Informação 
 
Ao importar o arquivo, o SPRING traz todo o conteúdo da carta, apesar de anteriormente, ao 
definir as características do seu PROJETO, já ter lhe informado as coordenadas geográficas da 
área de estudo. Para visualizar e trabalhar apenas com a área de estudo anteriormente 
informada é preciso realizar o CORTE DO PLANO DE INFORMAÇÃO.  
 
Menu → Ferramentas → Recortar Plano de Informação →  marcar Retângulo Envolvente; 
No campo Máscara, clique em Retângulo Envolvente → Projeto → Executar → Fechar. No 
campo Recorte, dê um nome de saída ao PI ativo. Neste campo aparecerão as opções interno 
e externo. Caso seu objetivo seja manter a área contida no retângulo envolvente, selecione 
interno. Caso contrário selecione externo. → Executar. 
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h) Exportar o arquivo para o MicroStation: 
 
Menu Arquivo → Exportar – Exportar em formato DXF-R12 
Coord → Planas (metros), Entidade → Amostras; → Salvar → Fechar. 
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2. GERAÇÃO DE MODELO DIGITAL DE TERRENO NO MICROSTATION 
 
2.1 Configurar o arquivo no MicroStation:  
       
Ao abrir o Microstation aparecerá a tela abaixo, na qual você deverá selecionar default  no 
campo Workspace: 
 

 
 
 
 
File → New; Abrirá a janela Creat Design File - No campo Select → Seed3d → OK; O 
arquivo semente deverá ser 3d, já que mais tarde vamos ativar o aplicativo Geoterrain para 
fazer a modelagem tridimensional.  
No campo Drives selecione a unidade onde seu arquivo será salvo, em Files dê um nome 
para o seu arquivo → Ok → Ok. 
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Uma vez aberta a tela de trabalho do MicroStation, devemos configurar as unidades de 
trabalho e salvá-las; 
 

 
 
Settings → Design File → Working Units – No campo Unit Names → Master Units (m) e 
Sub Units (cm), caso esteja trabalhando em metros. No campo Resolution → 100 cm per m – 
1 pos units per cm → Ok. 
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É muito importante que você salve suas alterações na configuração, como as unidades de 
trabalho: File → Save Settings  
 

 
  
 
 
2.2. Importar o arquivo DWG ou DXF 
 
File → Import → DWG or DXF → Selecionar, no campo List File of Type, AutoCad DXF. 
Em Files selecione o arquivo a ser aberto → Ok; Na janela Drawing File → Open. 
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OBS: Caso a imagem não apareça de imediato na tela clique em Fit View no canto inferior 
esquerdo da tela de trabalho de MicroStation. 
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2.3. Ativar o aplicativo Geoterrain: 
 
Agora que já importamos o arquivo DXF, vamos ativar o aplicativo topográfico e as 
respectivas ferramentas que nos proporcionarão fazer o Modelo Digital de Elevação MDE. 
Menu Applications → GEOPACK → Activate GEOPACK. Novamente no menu 
Applications → GEOPACK GEOTERRAIN → GEOPACK GEOTERRAIN Tools 

   
 
A barra de ferramentas abaixo aparecerá na tela: 
 

 
 
2.4. Extração dos dados 
 
Após a ativação das ferramentas do MicroStation Geoterrain, vamos extrair os dados do 
arquivo 3D usando a ferramenta Extract DGN Data. Para tal é preciso que você crie um 
arquivo DAT, conforme ilustrado na figura abaixo:  
 

 
 

Você deverá informar, no campo File Name (dê um click em File), o diretório no qual o 
arquivo DAT será gravado. 
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-No campo File type selecione ASCII 
-No campo File open selecione CREATE, pois vamos gerar arquivo e não adicionar dados a 
um arquivo que já existe. Caso fosse para o acréscimo de dados, como no exemplo de 
adicionar informações de pontos cotados às informações de curvas de nível, deveria ser 
utilizada a opção Append. 
-No campo Feature type selecione CONTOURS, uma vez que estamos trabalhando com 
curvas de nível. No caso de trabalhar com pontos com atributos, como os pontos cotados de 
topografia, selecionar a opção Spots. Caso esteja modelando topografias como bancadas de 
mineração, as linhas de quebra de pés os cristas de taludes devem vir como Breaks. Caso 
deseje definir uma área de contorno para a modelagem, cujos valores estejam em 3d, 
selecionar Boundary. 
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No campo Mode selecione EXTRACTION para extrair os dados numéricos do arquivo 
vetorial, o que nos proporcionara a criação do MDE. 
 
No campo Select Criteria selecione todos os níveis (Levels) na janela Level Mask, click uma 
vez com o botão esquerdo do mause e arraste o cursor sobre os números de 1 a 63. Como não 
vamos precisar mexer com o estilo, peso, tipo e cores do nosso arquivo de trabalho, serão 
deixados os respectivos itens desmarcados no campo em questão. 
 

     
  
Para visualizar o resultado, abra o arquivo DAT no bloco de notas. Ele é um arquivo que 
contém 4 colunas: a primeira informa a característica do vértice, a segunda a posição “x”, a 
terceira a posição “y” e a quarta a cota “z”. 
 
Observe o exemplo abaixo, e visualize um arquivo DAT para entender a apresentação. Caso o 
tipo de elemento seja um ponto (ou nó de vetor) interno à linha, o tipo de elemento será "1". 
Para ouyras funções dos nós, vide tabela de código de elementos. A compreensão fo formato 
da tabela permite que usuários iniciem uma modelagem digital de terreno pelos pontos 
cotados, construindo arquivo com 4 colunas e salvando-o com a extensão “dat”. 
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Codificação dos tipos de elementos para arquivo ASCII no Geoterrain: 

CÓDIGO TIPO 
1 Pontos aleatórios (spots) 
2 Início de linha quebrada (break line) 
3 Pontos subseqüentes de linha quebrada 
4 Pontos do polígono de contorno (boundary) 
5 Início de curva de nível (contours) 
6 Pontos subseqüentes de curva de nível 
7 Início de superfície plana (void) 
8 Pontos subseqüentes de superfície plana 

 
 
2.5 Geração do TIN 
 
Vamos agora gerar uma grade irregular de pontos, por interpolação, a partir do arquivo DXF 
importado, através da ferramenta Build TIN. A grade irregular de pontos é indicada para a 
representação das complexidades do relevo, pois tende a respeitar estruturas como hog backs1 
e vales muito encaixados. A grade TIN (do inglês Triangular Irregular Network) constitui 
uma estrutura vetorial com topologia do tipo nó – arco que representa a superfície por faces 
triangulares interligadas. Quanto mais eqüilátero forem os triangulas do TIN, melhor será a 
qualidade (exatidão) na modelagem do relevo.  
 

                                                 
1 Cristas ou colinas sustentadas por camadas mais resistentes à erosão. Ver glossário 
geológico da Universidade de Brasília-UnB:www.unb.br/ig/glossario/. 
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A caixa de construção de rede triangular “Build Triangles” aparecerá na tela do 
MicroStation, neste campo você deverá entrar com os dados extraído do arquivo importado 
com o objetivo de executar a triangulação. 
 

 
 
 
No campo Data File – click em Files para selecionar os dados extraídos que serviram de base 
para a geração do TIN, lembre-se que extensão do arquivo de entrada é .dat. 
No campo Tin File – click em Files e escolha o diretório no qual você ira salvar o arquivo 
TIN. Selecione Minimize Insert Break Points, de acordo com a figura acima, mas se o 
usuário quiser que a modelagem ocorra dentro dos limites de uma certa área devera marca 
Clip External to Boundary Polygon. Neste caso, o campo Dissolve Options devera estar 
indicando Sliver. Mas como não iremos trabalhar com tais especificações, vamos selecionar 
None click em Process para iniciar a triangulação. 
É importante que o usuário do MicroStation atente-se para as informações que o software 
lança no canto inferior direito e esquerdo da tela, são informações importantes pois avisam 
ações a serem executadas, o andamento de algumas ações, bem como o resultado delas. Após 
a triangulação que acabamos de fazer, por exemplo, o software lança a seguinte informação: 
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Uma vez processado o TIN, podemos visualizar a malha triangular através da ferramenta 
Display Triangles, pela qual abriremos a janela Load Triangles:  
 

 
 
Conforme os procedimentos executados anteriormente, no campo Tin File – selecionar o 
arquivo TIN gerado clicando em Files: 
 

 
 
Ao marcar Display Only o programa não registrará fisicamente a malha triangular, para tal 
você deverá marcar Set Graphic Group, pois o TIN será um único elemento gráfico.  
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Marcando Load Edge Polygons, “serão desenhados os polígonos ortogonais ao nível 
horizontal que fecha a caixa de desenho” (MOURA & ROCHA ; 2001). 
 
Ao selecionar Load Within Fence o MicroStation carregará o TIN somente nos limites na 
fence.  

 
  
Selecione o nível no qual o programa ira carregar seu TIN e click em Load para finalizar. 
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2.6. Geração do o LAT 
 
A grade retangular regular LAT tende a suavizar as complexidades do relevo, proporcionando um 
efeito visual mais bonito que o TIN. O LAT é uma representação matricial onde cada elemento 
associa-se a um valor numérico e é melhor adaptado para o tratamento de dados geofísicos, 
pedológicos e geoestatísticos. 
 
Acione a ferramenta Build Lattice para abrir a janela de mesmo nome: 

  

 
 

 
 
 
No campo File Tin - Files entre com arquivo TIN e no campo Lat File – Files selecione o 
diretório onde será salvo o LAT. 
Em Lattice Option deixe a opção Auto ativada. No campo Lattice Points você devera indicar 
o numero de pontos de sua malha regular – click.  
 
Tal número é calculado em função da resolução que você quer para o seu LAT, numa relação 
direta entre o total de linhas e colunas. Para calcular o numero de lattice points você devera 
dividir a largura e o comprimento de sua base topográfica pelo valor do padrão de exatidão 
cartográfica da mesma, atentando-se para a respectiva escala. Se você estiver trabalhando com 
uma área de 10 Km por 5 Km, por exemplo, em uma escala de 1:50000, sabendo que a PEC é 
de 10m, obterá uma malha de 1000 colunas por 500 linhas. O que daria um número de lattice 
points de 500.000. 
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Deve-se ressaltar, no entanto, que na definição do número de nós de Grid, ou os lattice points, 
o usuário considerar a finalidade do seu trabalho, haja vista que uma malha muito densa pode 
não carregar completamente e comprometer o resultado final da modelagem.  
 
Para visualizar a malha regular o procedimento e semelhante à visualização do TIN.  
 
  

 
  
 

 
 
 
Selecione a ferramenta Display Lattice, pela qual você abrira a janela Load Lattice. Marque a 
opção Set Graphic Group e escolha a cor e o nível onde a malha será carregada – click em 
Load. O programa informará ao usuário, conforme explicado anteriormente nesta apostila, 
quando a malha estiver totalmente pronta, bem como informará possíveis problemas na 
geração da mesma. 
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Para visualizar a simulação da superfície topográfica modelada, usando tanto a malha TIN 
quanto a malha LAT, você devera utilizar a ferramenta de renderizaçao para o tratamento de 
imagens de modelos 3D. No menu Utilities – Render – Smooth – perceba que o cursor do 
mause, ganhara o formato semelhante ao sinal de adição (+), você devera clicar uma vez sobre 
a malha carregada para fazer a renderizção. 
 

 
 

Para ajustar os atributos do tratamento da imagem, como a incidência solar na no relevo, você 
devera acionar a janela Global Lighting no menu Settings – Rendering -  Global Lighting.  
 
Deixe o campo Solar ativado e desmarque Lock. No campo Location informe uma latitude e 
longitude abrangente a sua malha. No campo Time selecione Daylight e escolha a hora e o 
mês e ano para aplicar a insolação. 
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2.7 Geração de mapas temáticos: Declividade e Hipsométrico  
 
Os mapas de declividade e Hipsométrico poderão ser gerados sobre a malha TIN ou a malha 
LAT, usando as ferramentas Tin Theme ou Lattice Theme respectivamente.  
 
Selecione o arquivo LAT ou TIN sobre o qual serão gerados os mapas – selecione Set 
Graphic Group.  
 
Em Theme selecione Height para gerar mapa Hipsométrico ou Slope Percentage 
(declividade em porcentagem) e Slope Degrees (declividade em graus°) para gerar mapa de 
declividade. 
 

 
 
  

 
 
 
No campo Preferences o usuário irá definir as classes de cotas altimétricas ou classes de 
declividade, em caso de gerar mapa de declividade. Preferences – Theme Ranges.  
 
Nos campos Lo e Hi, entre com os valores inicial e final, respectivamente, das classes a serem 
definidas. Entre com a primeira classe de valores - click em Col - e selecione uma cor – 
marque Act – Add.  
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Repita o procedimento para cada classe, caso você queira mudar o valor ou a cor de uma 
classe, marque a mesma e click em Modify. Você poderá salvar as classes em File – Save As.  
 

 
 

  
 
  
Mapa de Declividades:                                                         Mapa Hipsométrico: 
 
 
 

   
 
 

 29


